Custom Ordering a collection is no longer working

Having Trouble using the Playing Card Database? Post it here!

Moderator: Playing Card DB Mod

Custom Ordering a collection is no longer working

Unread postby flyers3003 » Thu Jul 28, 2016 5:28 pm  

I used custom ordering for my collection because I don't always name my decks the same way as they're entered. Within the past 2-3 months, this feature appears to have been broken, as any time I try to save after moving a deck I get an error "Sorry, there was a problem". Would really like to see this working again.
User avatar
flyers3003
Member
Sentinel
Sentinel
 
Posts: 287
Joined: Fri Jan 04, 2013 1:21 pm
Location: Charlottesville, Virginia
Country: United States (us)
Has thanked: 30 times
Been thanked: 51 times

Re: Custom Ordering a collection is no longer working

Unread postby 4.of.Clubs » Thu Jul 28, 2016 8:35 pm  

Maybe there's something with the collection, a bad node maybe? I use the custom ordering almost everyday (moving and saving order) without an issue.


----------> Check out the decks I have for sale! <----------


----------> Also check out my Trade List and Wish List, maybe we can make a deal! <----------
User avatar
4.of.Clubs
Member
Veteran
Veteran
 
Posts: 597
Joined: Sat May 30, 2015 11:38 am
Location: Texas
Country: United States (us)
Has thanked: 22 times
Been thanked: 81 times

Re: Custom Ordering a collection is no longer working

Unread postby flyers3003 » Thu Jul 28, 2016 9:30 pm  

Could be, but I don't know that I could easily find/fix it.
User avatar
flyers3003
Member
Sentinel
Sentinel
 
Posts: 287
Joined: Fri Jan 04, 2013 1:21 pm
Location: Charlottesville, Virginia
Country: United States (us)
Has thanked: 30 times
Been thanked: 51 times

Re: Custom Ordering a collection is no longer working

Unread postby ecNate » Thu Jul 28, 2016 10:25 pm  

I couldn't see any obvious broken node problems and the prior intermittent problem behavior we had in the past with reserved SQL characters ( like ' & etc) should be fully resolved with our move to the new platform on P52. I do see you have a bunch of decks with the 'NOT YET RELEASED' prefix which may have since been deleted or at least renamed, but that shouldn't cause the problem. I guess you could try manually removing those and try again, then re-add, but shot in the dark only. The other thing might be you have a huge collection of 1175 so it's possible there is an upper limit in the code/math somewhere, but I don't think that's possible with this new platform either. If somebody who has that many or more confirms it works then I guess that could be ruled out too. Perhaps a cache or file space issue on server or your browser side? I would try using another browser, increase cache space and clear it, clear logins/cookies, etc.... or just try a new browser to start with.
User avatar
ecNate
Member
Grandmaster
Grandmaster
 
Posts: 1915
Joined: Sat Mar 01, 2014 1:46 am
Location: Wisconsin
Country: United States (us)
Has thanked: 363 times
Been thanked: 359 times

Re: Custom Ordering a collection is no longer working

Unread postby flyers3003 » Fri Jul 29, 2016 1:02 am  

I'm inclined to believe it has something to do with the size of my collection. When I first enter the Custom Order Collection screen, 200 decks are present. If I hit Save Ordering at this point, I don't receive an error. I then hit Load More Decks, which loads an additional 100 decks and again hit Save Ordering with no error. I kept doing this until I had 1000 decks shown. Still no error. Once I loaded the next 100 to get to 1100 and hit Save Ordering, the error occurred. Trying to rule out that one of the 100 (1001-1100) decks was the issue, I went through each one, removed it from my collection and got to the point where 1100 decks were shown. Every time I got the error. If I had 1000 shown, no error. This would also make sense as it was about 2-3 months ago when I eclipsed 1000 decks. If someone with a collection > 1000 decks can confirm that they're able to use Custom Ordering with 1000+ on the screen at the time, that would prove me wrong.
User avatar
flyers3003
Member
Sentinel
Sentinel
 
Posts: 287
Joined: Fri Jan 04, 2013 1:21 pm
Location: Charlottesville, Virginia
Country: United States (us)
Has thanked: 30 times
Been thanked: 51 times

Re: Custom Ordering a collection is no longer working

Unread postby 4.of.Clubs » Fri Jul 29, 2016 9:46 am  

flyers3003 wrote:I'm inclined to believe it has something to do with the size of my collection. When I first enter the Custom Order Collection screen, 200 decks are present. If I hit Save Ordering at this point, I don't receive an error. I then hit Load More Decks, which loads an additional 100 decks and again hit Save Ordering with no error. I kept doing this until I had 1000 decks shown. Still no error. Once I loaded the next 100 to get to 1100 and hit Save Ordering, the error occurred. Trying to rule out that one of the 100 (1001-1100) decks was the issue, I went through each one, removed it from my collection and got to the point where 1100 decks were shown. Every time I got the error. If I had 1000 shown, no error. This would also make sense as it was about 2-3 months ago when I eclipsed 1000 decks. If someone with a collection > 1000 decks can confirm that they're able to use Custom Ordering with 1000+ on the screen at the time, that would prove me wrong.


AT 940... I'll let you know in a couple months. :D

One thing to note, I've always loaded all the decks THEN hit save ordering. One time I accidentally hit the save ordering before loading everything and the ordering of the decks that weren't loaded got messed up.


----------> Check out the decks I have for sale! <----------


----------> Also check out my Trade List and Wish List, maybe we can make a deal! <----------
User avatar
4.of.Clubs
Member
Veteran
Veteran
 
Posts: 597
Joined: Sat May 30, 2015 11:38 am
Location: Texas
Country: United States (us)
Has thanked: 22 times
Been thanked: 81 times

Re: Custom Ordering a collection is no longer working

Unread postby flyers3003 » Fri Jul 29, 2016 10:33 am  

4.of.Clubs wrote:One thing to note, I've always loaded all the decks THEN hit save ordering. One time I accidentally hit the save ordering before loading everything and the ordering of the decks that weren't loaded got messed up.


Yeah, I observed that too. I was ok with sacrificing the order to try and determine the cause of the error :-)
User avatar
flyers3003
Member
Sentinel
Sentinel
 
Posts: 287
Joined: Fri Jan 04, 2013 1:21 pm
Location: Charlottesville, Virginia
Country: United States (us)
Has thanked: 30 times
Been thanked: 51 times

Re: Custom Ordering a collection is no longer working

Unread postby ecNate » Fri Jul 29, 2016 11:04 am  

I did a bunch of digging around, but bottom line I don't have full server access to see all the configs and logs. My guess is it's a memory limitation and could possibly be fixed by updating the memory allocated to PHP, but it's also possible it's a bug fixed in a later version of the platform or modules.

I searched for a number of terms in the issues and change log, but couldn't find anything obvious

http://cgit.drupalcode.org/drupal/plain/core/CHANGELOG.txt
https://www.drupal.org/project/issues/draggableviews
https://www.drupal.org/project/issues/paging


At this point there's only 2 things I can do. The first is if you can try it again now and see if you get the error, then let me know when you got it. I can check the logs I have access to and see if there is anything helpful there (it only retains the last 2 hours since we still have spam/bot use that generate pages of 404 errors from trying to spider around to non-existent pages). The other thing I can do is let Alex know and see if he can have the dev guy look into it or at least be sure to review again after the next version and hopefully get all versions up to date.
User avatar
ecNate
Member
Grandmaster
Grandmaster
 
Posts: 1915
Joined: Sat Mar 01, 2014 1:46 am
Location: Wisconsin
Country: United States (us)
Has thanked: 363 times
Been thanked: 359 times

Re: Custom Ordering a collection is no longer working

Unread postby flyers3003 » Fri Jul 29, 2016 2:23 pm  

Just got the error again at ~3:22pm EST.
User avatar
flyers3003
Member
Sentinel
Sentinel
 
Posts: 287
Joined: Fri Jan 04, 2013 1:21 pm
Location: Charlottesville, Virginia
Country: United States (us)
Has thanked: 30 times
Been thanked: 51 times

Re: Custom Ordering a collection is no longer working

Unread postby ecNate » Fri Jul 29, 2016 3:27 pm  

So I'm just going to dump the errors here. Basically you got quite a few created, but others have had some with smaller collections and no known actual problems, but really I have no idea the impact of these. Still after reviewing them I dug into 3 of them more, 2 were on your custom page and the 3rd was more of anomaly and perhaps the root cause. I'll direct Alex to this thread and maybe he can have the dev take a look.

php 07/29/2016 - 20:13 User error: "total_decks_collected" is an invalid… flyers3003
php 07/29/2016 - 20:13 User error: "total_unique_decks" is an invalid render… flyers3003
php 07/29/2016 - 20:13 User error: "total_unique_images" is an invalid render… flyers3003
php 07/29/2016 - 20:13 User error: "recently_collected_decks" is an invalid… flyers3003
php 07/29/2016 - 20:13 User error: "newly_archived_decks" is an invalid render… flyers3003
php 07/29/2016 - 20:14 Warning: apc_store(): GC cache entry 'M34VdBeTDBssJ8XxE… flyers3003
php 07/29/2016 - 20:14 User error: "total_decks_collected" is an invalid… flyers3003
php 07/29/2016 - 20:14 User error: "total_unique_decks" is an invalid render… flyers3003
php 07/29/2016 - 20:14 User error: "total_unique_images" is an invalid render… flyers3003
php 07/29/2016 - 20:14 User error: "recently_collected_decks" is an invalid… flyers3003
php 07/29/2016 - 20:14 User error: "newly_archived_decks" is an invalid render… flyers3003
php 07/29/2016 - 20:20 User error: "total_decks_collected" is an invalid… flyers3003
php 07/29/2016 - 20:20 User error: "total_unique_decks" is an invalid render… flyers3003
php 07/29/2016 - 20:20 User error: "total_unique_images" is an invalid render… flyers3003
php 07/29/2016 - 20:20 User error: "recently_collected_decks" is an invalid… flyers3003
php 07/29/2016 - 20:20 User error: "newly_archived_decks" is an invalid render… flyers3003
php 07/29/2016 - 20:20 Notice: Undefined variable: cache in Drupal… flyers3003
php 07/29/2016 - 20:20 Notice: Undefined variable: data in Drupal\mycollection… flyers3003
php 07/29/2016 - 20:20 Notice: Undefined variable: cache in Drupal… flyers3003
php 07/29/2016 - 20:20 Notice: Undefined variable: data in Drupal\mycollection… flyers3003




Type php
Date Friday, July 29, 2016 - 20:20
User flyers3003
Location http://www.portfolio52.com/collection/52/images/custom.
Referrer http://www.portfolio52.com/collection/52/images.
Message <em class="placeholder">Notice</em>: Undefined variable: data in <em class="placeholder">Drupal\mycollection\Controller\ViewcollectionController-&gt;displayCollection()</em> (line <em class="placeholder">96</em> of <em class="placeholder">/var/www/html/releases/20151122194555/modules/mycollection/src/Controller/ViewcollectionController.php</em>).
Severity Notice


Type php
Date Friday, July 29, 2016 - 20:20
User flyers3003
Location http://www.portfolio52.com/collection/52/images/custom.
Referrer http://www.portfolio52.com/collection/52/images.
Message <em class="placeholder">Notice</em>: Undefined variable: cache in <em class="placeholder">Drupal\mycollection\Controller\ViewcollectionController-&gt;displayCollection()</em> (line <em class="placeholder">44</em> of <em class="placeholder">/var/www/html/releases/20151122194555/modules/mycollection/src/Controller/ViewcollectionController.php</em>).
Severity Notice


Type php
Date Friday, July 29, 2016 - 20:14
User flyers3003
Location http://www.portfolio52.com/user/52.
Referrer http://www.portfolio52.com/.
Message <em class="placeholder">Warning</em>: apc_store(): GC cache entry 'M34VdBeTDBssJ8XxE_lmVzIFW6sPBbbqwUbtk3yUoeg::config::rdf.mapping.node.deck' was on gc-list for 3607 seconds in <em class="placeholder">Drupal\Core\Cache\ApcuBackend-&gt;set()</em> (line <em class="placeholder">188</em> of <em class="placeholder">/var/www/html/releases/20151122194555/core/lib/Drupal/Core/Cache/ApcuBackend.php</em>).
Severity Warning
User avatar
ecNate
Member
Grandmaster
Grandmaster
 
Posts: 1915
Joined: Sat Mar 01, 2014 1:46 am
Location: Wisconsin
Country: United States (us)
Has thanked: 363 times
Been thanked: 359 times

Re: Custom Ordering a collection is no longer working

Unread postby ecNate » Mon Aug 01, 2016 12:07 pm  

Update - I talked to Alex about this and shared the details, but apparently the new site is really close (I got a direct sneak peek and indeed it is very close and pretty awesome). As a result it doesn't make sense to invest time/effort (aka $) into debugging this more since the new one will be a new platform and such issues should be automatically resolved.
User avatar
ecNate
Member
Grandmaster
Grandmaster
 
Posts: 1915
Joined: Sat Mar 01, 2014 1:46 am
Location: Wisconsin
Country: United States (us)
Has thanked: 363 times
Been thanked: 359 times

Re: Custom Ordering a collection is no longer working

Unread postby flyers3003 » Mon Aug 01, 2016 1:20 pm  

No worries. Looking forward to the updated site. Thanks for taking a look at it anyway.
User avatar
flyers3003
Member
Sentinel
Sentinel
 
Posts: 287
Joined: Fri Jan 04, 2013 1:21 pm
Location: Charlottesville, Virginia
Country: United States (us)
Has thanked: 30 times
Been thanked: 51 times


Return to Support Requests / Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest