Problems logging in - especially on HTTPS (secure) side

Have questions or comments about the site?

Problems logging in - especially on HTTPS (secure) side

Unread postby Mike Ratledge » Wed Mar 16, 2016 12:27 am  

If you are having problems where the system is forcing you to log in again (possibly over and over), clear your cache - usually <Shift><F5> on Windows-based browsers, no clue for Linux/iOS and for Android you have to use the Application manager to clear the cache for the browser(s0 apps. Again, mobile iOS - no clue, sorry.

The fact is that after me fighting with HostGator for almost ten days, they finally installed a new SSL certificate which expires in 1 year (again - don't know why, I pay 2 years at a time for hosting, and it's included - but never gets installed without me having to get online and usually on the phone and complain over and over and over again). When you install an SSL certificate, it changes the IP used for the HTTPS access, and I suppose could mess around with the DNS record for the standard side as well. What that means is that if you have cached cookies or IP to URL mappings, they are going to 'break' the requirement that they match the IP exactly - certainly for the SSL / HTTPS: access, and potentially for normal unencrypted access as well.
>Mike<

"You can't please everyone, so you've got to please yourself"
Moderating in moderation...

Members are encouraged to
Show Us Your Cards!


Dondorf "Hundertjahrkarte" (1933)
restoration sets still available:
Late Backers Link
Decks produced & gilded by Cartamundi
Restoration by Lotrek

Uncut sheets available here:
Uncuts by Cartamundi


UC members help maintain Portfolio52
THE Playing Card Database Online
Contact ecNate for details and access


UC2017 Fifth Annual Decks
"Avant-garde" by Edgy Brothers
Fulfillment completed

Stay tuned for UC2018
decks by Rick Davidson


v2 Carat Card Cases™
single, double, triple & quad
US / Canadian / Overseas
shipping by Priority Mail
>>> UC Deck Sales <<<


Insert disclaimer here...
All information posted as fact is accurate at the time of posting to the best of my knowledge.
User avatar
Mike Ratledge
Site Admin
Card Oracle
Card Oracle
 
Posts: 5026
Joined: Sat Nov 02, 2013 4:25 pm
Location: Awendaw/McClellanville (Charleston county) S.C.
Country: Denmark (dk)
Has thanked: 1593 times
Been thanked: 442 times

Re: Problems logging in - especially on HTTPS (secure) side

Unread postby ecNate » Wed Mar 16, 2016 9:32 am  

For me nothing fixed the problem related to cache/history, I even cleared EVERYTHING (including all logins/passwords). The only time it would log me out again is when I went to my bookmark (http://unitedcardists.com/search.php?se ... nreadposts.) and then immediately would log me out, but manually navigating around was fine before.

I then logged in using HTTPS and then updated my bookmark to HTTPS (search.php?search_id=unreadposts.) and now it all works.

So I think the solution is to have everybody fully switch over to HTTPS (which is always a good idea anyhow) as the non-SSL method still has bugs that logs people out no matter how much they clear cache.

- Was using Chrome Version 48.0.2564.116 m (will update and see if any improvement if that was related)


EDIT - something still screwy as I just got logged out again, but using my unread bookmark and jumping around still fine for a while now again.
User avatar
ecNate
Member
Grandmaster
Grandmaster
 
Posts: 1983
Joined: Sat Mar 01, 2014 1:46 am
Location: Wisconsin
Country: United States (us)
Has thanked: 379 times
Been thanked: 383 times

Re: Problems logging in - especially on HTTPS (secure) side

Unread postby montecarlojoe » Wed Mar 16, 2016 10:47 am  

The only reason to clear cache / history is to flush all those old URLS that still use the HTTP protocol. (Chrome loves to present you with often visited sites for example)

I have found that chrome will tend to log you out after you close the browser, but IE doesn't. I'll poke about to see if there's a setting for time limited cookies to be turned off.
(Of course this could be to do with the chrome settings!)
User avatar
montecarlojoe
Moderator
Legendary Member
Legendary Member
 
Posts: 2467
Joined: Mon Jun 24, 2013 7:10 am
Location: Portsmouth, England
Country: United Kingdom (uk)
Has thanked: 245 times
Been thanked: 273 times

Re: Problems logging in - especially on HTTPS (secure) side

Unread postby 4.of.Clubs » Wed Mar 16, 2016 2:27 pm  

I switched to HTTP a while back from HTTPS since Chrome kept complaining about the certificate, and had issues staying logged in past few days.

Switching back to HTTPS like Nate mentioned fixed the problem. Thanks!


----------> Check out the decks I have for sale! <----------


----------> Also check out my Trade List and Wish List, maybe we can make a deal! <----------
User avatar
4.of.Clubs
Member
Veteran
Veteran
 
Posts: 602
Joined: Sat May 30, 2015 11:38 am
Location: Texas
Country: United States (us)
Has thanked: 22 times
Been thanked: 82 times

Re: Problems logging in - especially on HTTPS (secure) side

Unread postby Talisman » Sat Jul 16, 2016 11:06 pm  

Is anyone besides myself having problems with staying logged in even after having the box checked to log in every time you visit the site?
User avatar
Talisman
Member
Sentinel
Sentinel
 
Posts: 255
Joined: Thu Feb 19, 2015 7:57 pm
Location: New York
Country: United States (us)
Has thanked: 136 times
Been thanked: 32 times

Re: Problems logging in - especially on HTTPS (secure) side

Unread postby shermjack » Sun Jul 17, 2016 2:04 am  

Yes, and it has gotten worse recently, but only in my laptop...for some reason, I stay logged on when I use my iPad...strange :?
A deck a day helps keep the addiction at bay
User avatar
shermjack
Member
Ace
Ace
 
Posts: 786
Joined: Mon Feb 23, 2015 7:39 pm
Country: United States (us)
Has thanked: 203 times
Been thanked: 260 times

Re: Problems logging in - especially on HTTPS (secure) side

Unread postby JuFiN » Sun Jul 17, 2016 1:51 pm  

same here Ipad has remained logged in for a good month now, on PC if I refresh the forums after 30-45 minutes it logs me out. The worst is when im writing a long post and hit submit and it takes me to the log in screen because I have to be logged in to post. Then I have to rewrite the post from the beginning! Gotten into the habit of copying all my posts into a word document before submitting for fear of losing it.
User avatar
JuFiN
Member
Sentinel
Sentinel
 
Posts: 271
Joined: Mon May 23, 2016 12:07 pm
Location: Massachusetts
Country: United States (us)
Has thanked: 34 times
Been thanked: 62 times

Re: Problems logging in - especially on HTTPS (secure) side

Unread postby Talisman » Sun Jul 17, 2016 4:09 pm  

Thanks for your responses. I thought I was doing something wrong and now I'm relieved that it's not just me.
User avatar
Talisman
Member
Sentinel
Sentinel
 
Posts: 255
Joined: Thu Feb 19, 2015 7:57 pm
Location: New York
Country: United States (us)
Has thanked: 136 times
Been thanked: 32 times

Re: Problems logging in - especially on HTTPS (secure) side

Unread postby shermjack » Sun Jul 17, 2016 4:22 pm  

JuFiN wrote:The worst is when im writing a long post and hit submit and it takes me to the log in screen because I have to be logged in to post. Then I have to rewrite the post from the beginning! Gotten into the habit of copying all my posts into a word document before submitting for fear of losing it.


JuFin, when this happens, try hitting the 'back' button (previous page) to go back to your last page, your message still might be there. Try to re-submit it and if it gives you the same error, then repeat and copy/paste.
A deck a day helps keep the addiction at bay
User avatar
shermjack
Member
Ace
Ace
 
Posts: 786
Joined: Mon Feb 23, 2015 7:39 pm
Country: United States (us)
Has thanked: 203 times
Been thanked: 260 times

Re: Problems logging in - especially on HTTPS (secure) side

Unread postby montecarlojoe » Sun Jul 17, 2016 5:09 pm  

I had teething problems myself when we first switched over to https - but after clearing cookies etc and making sure my shortcuts included the HTTPS part I don't have an issue on any platfrom.

THat last one cause the most problems for me! So its a good idea to check any pinned favourites, desktop shortcuts etc, and even delete your history so autofill doesn't try to take you to the HTTP address.
User avatar
montecarlojoe
Moderator
Legendary Member
Legendary Member
 
Posts: 2467
Joined: Mon Jun 24, 2013 7:10 am
Location: Portsmouth, England
Country: United Kingdom (uk)
Has thanked: 245 times
Been thanked: 273 times

Re: Problems logging in - especially on HTTPS (secure) side

Unread postby Talisman » Sun Jul 17, 2016 7:40 pm  

My problems started when I deleted my history and cache on Chrome. That's when I noticed.
User avatar
Talisman
Member
Sentinel
Sentinel
 
Posts: 255
Joined: Thu Feb 19, 2015 7:57 pm
Location: New York
Country: United States (us)
Has thanked: 136 times
Been thanked: 32 times


Return to Site Announcements & Support

Who is online

Users browsing this forum: No registered users and 2 guests